使用过程遇到问题请先仔细参考 科学上网常见问题。如果不能解决您的问题,欢迎到 网络跳越论坛 查看解决方案和交流。

应网友请求,今天做了Ubuntu(仅支持Ubuntu 16.04及以上版本)系统的v2ray的一键安装脚本,目前已经上传到 Github。如果您的系统是CentOS,请参考这个教程: v2ray一键脚本

提示:这是自行搭建科学上网环境的第三步,请确认已经做了前两步:

  1. 购买服务器。想要服务器速度快请参考 搬瓦工购买服务器详细教程购买AkkoCloud德国、美西CN2 GIA VPS ,想ip被封后免费换请参考:购买vultr服务器超详细图文教程
  2. 连接到服务器。Windows系统请参考 Bitvise连接Linux服务器教程,mac用户请参考 Mac电脑连接Linux教程

注意:

1. 如果你有域名,强烈建议使用 v2ray带伪装一键脚本Ubuntu版,能有效应付近些天的疯狂封杀,提供稳如狗的体验!

2. 理论上只要流量够、服务器扛得住,同一个配置支持无数人、无限设备使用。如果想为不同的人配置不同的id,请参考:v2ray多用户配置

3. BBR换成魔改BBR/BBR Plus/锐速清参考:安装魔改BBR/BBR Plus/锐速(Lotserver)

4. 这两天官方脚本会出现“unzip: cannot find zipfile directory in one of /tmp/v2ray/v2ray.zip or
/tmp/v2ray/v2ray.zip.zip, and cannot find /tmp/v2ray/v2ray.zip.ZIP, period.
Failed to copy V2Ray binary and resources.”的抽风现象,本站一键脚本已经做了兼容修复;

5. 近日v2ray爆出裸tcp协议流量精确识别的漏洞,建议更新服务端和客户端,或使用 v2ray带伪装一键脚本

使用教程

登录到服务器(windows请参考 Bitvise连接Linux服务器教程,mac用户请参考 Mac电脑连接Linux教程),在终端(黑框框)里输入如下命令:

bash <(curl -sL https://raw.githubusercontent.com/hijkpw/scripts/master/ubuntu_install_v2ray.sh)

按回车键,屏幕出现 “请设置v2ray的端口[1-65535]” 的提示,设置v2ray端口号(例如12345,不能是22)。

接下来屏幕上会疯狂出现一些你看得懂看不懂的东西,如果安装过程卡住,请耐心等待几分钟;期间网络断开(windows上表现为黑框框中或者顶部标题出现disconnected字样,mac表现为终端出现“closed by remote host”或”broken pipe”),请重新连接后再次执行命令。脚本安装成功后截图如下:

v2ray一键安装脚本

v2ray一键安装脚本

到此服务端配置完毕,服务器可能会自动重启(没提示重启则不需要),windows终端出现“disconnected”,mac出现“closed by remote host”说明服务器成功重启了

V2ray一键脚本做了如下事情:

  1. 更新系统到最新版
  2. 安装bbr加速模块
  3. 安装v2ray并设置开机启动

注意:本站的一键脚本与其他网站的不能混合使用,如果之前运行过其他的请先卸载,否则可能导致无法上外网!

客户端下载

接下来是科学上网最后一步:下载客户端,并参考页面中的配置教程进行配置:

v2ray windows客户端下载

v2ray安卓客户端下载

v2ray mac客户端下载

v2ray ios客户端下载

下载客户端配置好后,就可以愉快的上外网了!

其他

1. 查看配置运行状态/参数:bash <(curl -sL https://raw.githubusercontent.com/hijkpw/scripts/master/ubuntu_install_v2ray.sh) info

2. v2ray管理命令:启动:systemctl start v2ray,停止:systemctl stop v2ray,重启:systemctl restart v2ray

3. 更改端口、alterid最简单的办法:重新运行一键脚本

4. 更新v2ray到最新版:bash <(curl -L -s https://install.direct/go.sh)

5. 卸载命令: bash <(curl -sL https://raw.githubusercontent.com/hijkpw/scripts/master/ubuntu_install_v2ray.sh) uninstall

参考

1. v2ray教程

文章最后修改日期:2020年6月14日


218 条评论

头像

surevv · 2020年7月22日 15:19

BUG:安装过程中设置的不是443 端口;安装完成提升的是443 ,正常的vmess 也是443.

    跳越者

    跳越者 · 2020年7月22日 15:56

    收到,感谢反馈

头像

BELINDA · 2020年7月21日 18:57

一键脚本搞不明白,急。手机1750347

    跳越者

    跳越者 · 2020年7月21日 19:04

    小白直接买机场服务吧,本站搜just my socks

头像

tgby · 2020年7月14日 22:04

大佬,有没有国内的下载地址,想在北京的服务器上安装v2ray,但是脚本上的地址安装v2ray的时候被墙了

    跳越者

    跳越者 · 2020年7月14日 22:36

    暂时没有适合国内的安装jiao ben

头像

hrbeta · 2020年7月10日 12:47

[root /]# bash <(curl -sL https://raw.githubusercontent.com/hijkpw/scripts/master/ubuntu_install_v2ray.sh)
#############################################################
# Ubuntu 16.04 TLS v2ray 带一键安装脚本 #
# 网址: https://www.hijk.pw #
# 作者: hijk #
#############################################################

系统版本: Distributor ID: Ubuntu
Description: Ubuntu 20.04 LTS
Release: 20.04
Codename: focal
端口号: 21568更新系统…Hit:1 http://archive.ubuntu.com/ubuntu focal InReleaseHit:2 http://archive.ubuntu.com/ubuntu focal-updates InReleaseHit:3 http://archive.ubuntu.com/ubuntu focal-backports InReleaseHit:4 http://archive.ubuntu.com/ubuntu focal-security InReleaseReading package lists…Building dependency tree…
Reading state information…
79 packages can be upgraded. Run 'apt list –upgradable' to see them.安装必要软件BBR模块已安装
安装v2ray…v2ray安装成功!============================================
v2ray运行状态:[0;32m正在运行[0m
v2ray配置文件:[0;31m/etc/v2ray/config.json[0m

[0;31mv2ray配置信息:[0m
IP(address): [0;31m74.120.170.119[0m
端口(port):[0;31m21568[0m
id(uuid):[0;31m14847ce6-894f-43ac-8cba-92317c515a56[0m
额外id(alterid): [0;31m70[0m
加密方式(security): [0;31mauto[0m
传输协议(network): [0;31mtcp[0m

vmess链接: vmess://eyAidiI6IjIiLCAicHMiOiIiLCAiYWRkIjoiNzQuMTIwLjE3MC4xMTkiLCAicG9ydCI6IjIxNTY4IiwgImlkIjoiMTQ4NDdjZTYtODk0Zi00M2FjLThjYmEtOTIzMTdjNTE1YTU2IiwgImFpZCI6IjcwIiwgIm5ldCI6InRjcCIsICJ0eXBlIjoibm9uZSIsICJob3N0IjoiIiwgInBhdGgiOiIiLCAidGxzIjoiIiB9

No LSB modules are available./dev/fd/63: line 72: nginx: command not found

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
WARNING: apt does not have a stable CLI interface. Use with caution in scripts.E: dpkg was interrupted, you must manually run 'dpkg –configure -a' to correct the problem.

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.E: dpkg was interrupted, you must manually run 'dpkg –configure -a' to correct the problem.

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.E: dpkg was interrupted, you must manually run 'dpkg –configure -a' to correct the problem. [36mLatest version v4.26.0 is already installed.[0m10 Jul 12:45:19 ntpdate[23996]: no server suitable for synchronization found

屏幕 没有出现 “按回车键,屏幕出现 “请设置v2ray的端口[1-65535]” 的提示,设置v2ray端口号(例如12345,不能是22)。”

    跳越者

    跳越者 · 2020年7月10日 15:17

    你这是网页终端吧?用ssh终端连过去运行

头像

kcloc · 2020年7月9日 11:42

大神,我安装完之后能正常使用,但是有一段时间不用之后,服务器就自动停止了,需要用root账号重新restart一下才行,每次都这样挺麻烦的,可以问下是什么原因吗。用看状态的指令看到是已停止,服务器是AWS免费的EC2,系统是linux 16.04,谢谢!

    跳越者

    跳越者 · 2020年7月9日 14:26

    可能是你服务器的内存太少了

      头像

      kcloc · 2020年7月16日 16:36

      1G内存也不够吗。。。

        跳越者

        跳越者 · 2020年7月16日 16:48

        1GB够用的,df -h,看看硬盘还有没有空间了

发表评论

电子邮件地址不会被公开。 必填项已用*标注